NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

FTP fails with NB 7.0.1 and Java 7
Goto page Previous  1, 2
 
Post new topic   Reply to topic    NetBeans Forums -> PHP Users
View previous topic :: View next topic  
Author Message
Jay-wo



Joined: 04 Sep 2011
Posts: 5
Location: Fullerton, California

PostPosted: Wed Sep 07, 2011 9:40 pm    Post subject: Reply with quote

Bob. You're right. I meant to say JRE. The issue still applies though, and the customer for my software wants it "to just work." Requiring the user to download software so that my software works will result in them not using my software. Sucks to be me. Smile
Back to top
Tomas Mysik
Posted via mailing list.





PostPosted: Thu Sep 08, 2011 5:34 am    Post subject: FTP fails with NB 7.0.1 and Java 7 Reply with quote

Hi,

Dne
Back to top
JeffRubinoff



Joined: 03 Dec 2008
Posts: 70
Location: Prague

PostPosted: Thu Sep 08, 2011 2:10 pm    Post subject: Reply with quote

Tomas' reply got eaten on the forum because of Czech diacriticals in the timestamp. Here is what he wrote:
Quote:
> we have discovered that it is a firewall issue.
so it seems to really be an issue of the Windows firewall - I have found
similar problem [1] with steps how to solve it. And one more post [2] on
stackoverflow.com.

HTH,
Tomas
[1] http://www.enterprisedt.com/forums/viewtopic.php?p=10700
[2] http://stackoverflow.com/questions/6990663/java-7-prevents-ftp-transfers-on-windows-vista-and-7-if-firewall-is-on-any-ideas
Back to top
khishigbaatar



Joined: 13 Sep 2011
Posts: 1

PostPosted: Tue Sep 13, 2011 12:39 pm    Post subject: SOLVED! Reply with quote

It's all about windows firewall. When you disable your windows firewall. NB ftp connection goes well.

Fix for windows firewall for passive ftp connection:

1. Open cmd.exe as Administrator
2. Run following command:
Code:
netsh advfirewall firewall add rule name=”FTP Service” action=allow service=ftpsvc protocol=TCP dir=in

And disable stateful ftp filtering:
Code:
netsh advfirewall set global StatefulFTP disable
Back to top
yetikov



Joined: 06 Sep 2011
Posts: 2

PostPosted: Tue Sep 20, 2011 3:39 pm    Post subject: Reply with quote

Thank you, khishigbaatar, for the code supplied.

Even though your first command failed because of invalid arguments. But I just ran cmd.exe with Administrator rights. And the following code was enough to solve the problem:

Code:
netsh advfirewall set global StatefulFTP disable
Back to top
sindy12



Joined: 13 Apr 2012
Posts: 1

PostPosted: Fri Apr 13, 2012 1:47 pm    Post subject: Reply with quote

Hi,
thank you, exactly what I'm looking for!
Back to top
mikenytola



Joined: 15 Oct 2010
Posts: 2

PostPosted: Sat Apr 14, 2012 9:02 pm    Post subject: Reply with quote

It's still missing a step.

If you still cannot connect, make sure that the FTP is set to Passive Mode.
Back to top
jhsachs



Joined: 25 Dec 2010
Posts: 56
Location: Northern California

PostPosted: Tue May 29, 2012 7:43 pm    Post subject: Reply with quote

khishigbaatar, could you please post a corrected form of the first command?

My configuration is not working, and I need to find the reason. If the first netsh command is at fault, having the correct version will fix if. If something else is at fault, having the correct version will eliminate that as a possible cause and allow me to concentrate my attention elsewhere.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> PHP Users All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo