NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

“Cannot connect to the debugged process” with Ruby on Netbeans

 
Post new topic   Reply to topic    NetBeans Forums -> Ruby Users
View previous topic :: View next topic  
Author Message
OtagoHarbour



Joined: 18 Nov 2011
Posts: 10

PostPosted: Thu May 05, 2016 1:14 pm    Post subject: “Cannot connect to the debugged process” with Ruby on Netbeans Reply with quote

I have installed Netbeans 8.1 on Ubuntu 14.04. I have installed the plugin 1434628827_ruby_and_rails. I have ruby-debug, version 0.10.5.rc2, installed along with ruby-debug-base(0.10.5.rc2 java) and ruby-debug-ide (0.4.17.beta14).

I start a new project with the option "Ruby Application". I enter some code, try to run it in debug mode and nothing happens. I then choose

Quote:
Attach Debugger ...


I take the default options

Quote:
Debugger: Ruby Debugger (ruby-debug-ide)
Host: localhost
Port: 7000
Timeout [2]: 15


After 15 seconds, I get the message

Quote:
Problem occurred during debugger start: Cannot connect to the debugged process at port 7000 in 15s
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> Ruby Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo