NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

Undeploy and deploy fail when running or deploying sample servlet

 
Post new topic   Reply to topic    NetBeans Forums -> Java EE Users
View previous topic :: View next topic  
Author Message
scottd



Joined: 05 Sep 2008
Posts: 28

PostPosted: Tue Jun 25, 2013 11:58 pm    Post subject: Undeploy and deploy fail when running or deploying sample servlet Reply with quote

Linux Mint 14
Sun JDK 1.7
Tomcat 7
NB 7.3.1

this is a new install of NetBeans

When I run or deploy the AsyncRequest example app I get the following errors.

Undeploying ...
undeploy?path=/
FAIL - Unable to delete [/var/lib/tomcat7/webapps/ROOT]. The continued presence of this file may cause problems.
In-place deployment at /home/scott/NetBeansProjects/AsyncRequest/build/web
Deployment is in progress...
deploy?config=file%3A%2Ftmp%2Fcontext7515576447094974414.xml&path=/
FAIL - Application already exists at path /
/home/scott/NetBeansProjects/AsyncRequest/nbproject/build-impl.xml:1020: The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 0 seconds)

the tomcat log says

Jun 25, 2013 5:40:36 PM org.apache.catalina.core.ApplicationContext log
INFO: Manager: undeploy: Undeploying web application at '/'
Jun 25, 2013 5:40:36 PM org.apache.catalina.core.ApplicationContext log
INFO: Manager: install: Installing context configuration at 'file:/tmp/context1384015059219788510.xml'
Jun 25, 2013 5:49:51 PM org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextDestroyed()

All the Tomcat sample apps run fine.

It looks like some kind of access problem but I'm not sure?

Scott
Back to top
scottd



Joined: 05 Sep 2008
Posts: 28

PostPosted: Wed Jun 26, 2013 3:32 am    Post subject: Possible work around Reply with quote

By setting the Context Path the deploy succeeds.

Project->properties-Run set Context Path to '/fubar' press OK Very Happy
Back to top
jyeary



Joined: 21 Oct 2008
Posts: 639
Location: Simpsonville, SC

PostPosted: Mon Jul 01, 2013 1:08 pm    Post subject: Undeploy and deploy fail when running or deploying sample servlet Reply with quote

Hello Scott,

Did you stop Tomcat, and clean the project? If you need to stop the the server to un-deploy it, please open an issue to get it fixed.


Thanks,


John

____________________________


John Yeary
____________________________
Back to top
scottd



Joined: 05 Sep 2008
Posts: 28

PostPosted: Fri Jul 05, 2013 8:25 pm    Post subject: Reply with quote

I stopped and started it a couple times, no difference.
Back to top
Bombisz



Joined: 20 Sep 2016
Posts: 5

PostPosted: Wed Sep 21, 2016 9:48 am    Post subject: Reply with quote

Hi, I have the same problem "The module has not been deployed". Did you fix it?
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> Java EE Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo