NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

NetBeans crashing on Windows 7

 
Post new topic   Reply to topic    NetBeans Forums -> Ruby Users
View previous topic :: View next topic  
Author Message
ReggieB



Joined: 21 Oct 2008
Posts: 63
Location: West Midlands, UK.

PostPosted: Wed Mar 31, 2010 11:48 am    Post subject: NetBeans crashing on Windows 7 Reply with quote

Hi,

I've recently started developing on a new computer (new employer). I am getting occasional NetBeans crashes and they are starting to get annoying. They tend to happen about once a day. There doesn't appear to be any consistency to them. I can be working on a ruby file and suddenly NetBeans vanishes. No error message, and no logs in Event viewer. All my other application carry on as if nothing has happened.

When I restart NetBeans it starts without any errors or unusual message, but with everything as it was a short while before the crash. I tend not to lose too much as I save fairly often to run unit and functional tests. So its mainly an annoyance - tends to break my train of thought.

The only remnant can be the web server (mongel) instances remain but in a stalled state and I have to kill the Ruby processes to get them working again. However, the crash can happen when I am not running any servers so I believe this is a symptom and not a cause.

I thought the problem may be version 6.8, so I installed 6.7.1 a couple of days ago and I thought that had sorted me out. However, 6.7.1 has crashed in just the same way as 6.8.

My system is:
Windows 7 Pro (64-bit)
Intel Q8400 2.67GHz
4 Gb RAM
JRE 6

Can anyone point me in the right direction to try and fix this?

Erno, I'll send you a couple of dumps from the profiler via e-mail in case that is any help.

Thank you

Reggie
Back to top
Erno Mononen
Posted via mailing list.





PostPosted: Wed Mar 31, 2010 12:35 pm    Post subject: NetBeans crashing on Windows 7 Reply with quote

Hi Reggie,

Thanks for the snapshot, I'll take a look at it. I'm afraid though that
it sounds like you're experiencing JVM crashes, for which we can't
usually do much about on the NB side. But please look for
hs_err_pid*.log files in your home dir and NB install dir (perhaps also
in the NB user dir, I can't recall now where the JVM creates them and
might be system specific anyway) and send those files to me. Also
please make sure you're running NB on the latest JDK 6, namely 6 update 19.

Thanks,
Erno

ReggieB wrote:
Quote:
Hi,

I've recently started developing on a new computer (new employer). I am getting occasional NetBeans crashes and they are starting to get annoying. They tend to happen about once a day. There doesn't appear to be any consistency to them. I can be working on a ruby file and suddenly NetBeans vanishes. No error message, and no logs in Event viewer. All my other application carry on as if nothing has happened.

When I restart NetBeans it starts without any errors or unusual message, but with everything as it was a short while before the crash. I tend not to lose too much as I save fairly often to run unit and functional tests. So its mainly an annoyance - tends to break my train of thought.

The only remnant can be the web server (mongel) instances remain but in a stalled state and I have to kill the Ruby processes to get them working again. However, the crash can happen when I am not running any servers so I believe this is a symptom and not a cause.

I thought the problem may be version 6.8, so I installed 6.7.1 a couple of days ago and I thought that had sorted me out. However, 6.7.1 has crashed in just the same way as 6.8.

My system is:
Windows 7 Pro (64-bit)
Intel Q8400 2.67GHz
4 Gb RAM
JRE 6

Can anyone point me in the right direction to try and fix this?

Erno, I'll send you a couple of dumps from the profiler via e-mail in case that is any help.

Thank you

Reggie





Back to top
ReggieB



Joined: 21 Oct 2008
Posts: 63
Location: West Midlands, UK.

PostPosted: Wed Mar 31, 2010 1:36 pm    Post subject: Reply with quote

Thanks Erno,

JVM problem sounds likely to me. Especially with this being a Windows 64 bit OS.

I was running JDK 6.18, so have upgraded to 6.19. Hopefully that will improve matters.

Thank you again.

Reggie
Back to top
ReggieB



Joined: 21 Oct 2008
Posts: 63
Location: West Midlands, UK.

PostPosted: Wed Mar 31, 2010 1:38 pm    Post subject: Reply with quote

Oh! and no sign of hs_err_pid*.log files. I search my whole PC. I then searched my profile for *.log files which found the NetBeans install logs but no error logs.

Reggie
Back to top
Erno Mononen
Posted via mailing list.





PostPosted: Thu Apr 01, 2010 2:59 pm    Post subject: NetBeans crashing on Windows 7 Reply with quote

That's strange, maybe the JVM fails to write it for some reason when it
crashes. Anyway, if the problems don't go away with JDK 6u19, please add

J-XX:ErrorFile=/some/path/hs_err_pid<pid>.log

to netbeans_default_options in <nb_install_dir>/etc/netbeans.conf. Then
when the JVM crashes again, we'll know that the error file should be
found in /some/path (if the JVM writes it).

Thanks,
Erno


ReggieB wrote:
Quote:
Oh! and no sign of hs_err_pid*.log files. I search my whole PC. I then searched my profile for *.log files which found the NetBeans install logs but no error logs.

Reggie





Back to top
ReggieB



Joined: 21 Oct 2008
Posts: 63
Location: West Midlands, UK.

PostPosted: Tue Apr 06, 2010 8:06 am    Post subject: Reply with quote

Thanks Erno,

I've added that line to my config file.

Reggie.
Back to top
ReggieB



Joined: 21 Oct 2008
Posts: 63
Location: West Midlands, UK.

PostPosted: Thu Apr 08, 2010 2:15 pm    Post subject: Reply with quote

In the hope that stating the following doesn't scupper everything....

My NetBeans crashes seem to have gone away since I upgrade the JDK.

I'm not sure if JDK 6.18 was the problem, or if my Java engine just needed reinstalling (I suspect the latter).

Thank you again Erno. Once again you've pointed me in the right direction.

Reggie.
Back to top
Erno Mononen
Posted via mailing list.





PostPosted: Thu Apr 08, 2010 2:50 pm    Post subject: NetBeans crashing on Windows 7 Reply with quote

Hi Reggie,
Glad to hear the crashes are gone, whatever the cause was.

Cheers,
Erno

ReggieB wrote:
Quote:
In the hope that stating the following does scupper everything....

My NetBeans crashed seem to have gone away since I upgrade the JDK.

I'm not sure if JDK 6.18 was the problem, or if my Java engine just needed reinstalling (I suspect that latter).

Thank you again Erno. Once again you've pointed me in the right direction.

Reggie.





Back to top
amasino



Joined: 10 Jun 2010
Posts: 4

PostPosted: Thu Jun 10, 2010 6:16 pm    Post subject: Reply with quote

I have had a similar problem but it has not gone away after updating to JDK 6.20. Specifically, I am developing a NetBeans platform application on a Windows 7 Professional (x64) machine. On many occasions where I launch the app from NetBeans and it (the app under dev) encounters an exception the following occurs:

1. The app can no longer be started from NetBeans. When executing a clean and build and then run command the app appears to build, but is never launched
2. If I then close NetBeans, I cannot reopen it in the normal manner. If I double click the icon nothing happens. I can launch from a command prompt, but I get a message stating "The launcher has determined that the parent process has a console and will reuse it ...". When NetBeans is started in this manner, the dev app will not launch (same behavior as 1)
3. I do get an hs_err_pid# file. I can provide them if needed.
4. I can find no consistent way to resolve the problem other than reinstalling NetBeans, which is obviously less than ideal.

This problem does not occur on any of our 32 bit Vista machines.

Any help you could provide would be greatly appreciated.
Back to top
Erno Mononen
Posted via mailing list.





PostPosted: Fri Jun 11, 2010 6:53 am    Post subject: NetBeans crashing on Windows 7 Reply with quote

Hello,

Since this is about developing a NB platform app, you may want to post
this to address-removed /
http://forums.netbeans.org/platform-users.html. Anyway, when NB refuses
to start normally, clearing the userdir or starting the IDE with a
different userdir should be enough instead of needing to reinstall the
whole IDE - please see http://wiki.netbeans.org/FaqAlternateUserdir for
more info. As for the main issue, please do post this to the
aforementioned platform dev list, I'm sure the folks there will try to
help in resolving it.

Thanks,
Erno


amasino wrote:
Quote:
I have had a similar problem but it has not gone away after updating to JDK 6.20. Specifically, I am developing a NetBeans platform application on a Windows 7 Professional (x64) machine. On many occasions where I launch the app from NetBeans and it (the app under dev) encounters an exception the following occurs:

1. The app can no longer be started from NetBeans. When executing a clean and build and then run command the app appears to build, but is never launched
2. If I then close NetBeans, I cannot reopen it in the normal manner. If I double click the icon nothing happens. I can launch from a command prompt, but I get a message stating "The launcher has determined that the parent process has a console and will reuse it ...". When NetBeans is started in this manner, the dev app will not launch (same behavior as 1)
3. I do get an hs_err_pid# file. I can provide them if needed.
4. I can find no consistent way to resolve the problem other than reinstalling NetBeans, which is obviously less than ideal.

This problem does not occur on any of our 32 bit Vista machines.

Any help you could provide would be greatly appreciated.





Back to top
amasino



Joined: 10 Jun 2010
Posts: 4

PostPosted: Fri Jun 11, 2010 12:14 pm    Post subject: Re: NetBeans crashing on Windows 7 Reply with quote

Oops. Didn't realize I posted this to the Ruby user forum. Sorry about that. I will repost as you suggested.
Thanks,
Aaron

Erno Mononen wrote:
Hello,

Since this is about developing a NB platform app, you may want to post
this to address-removed /
http://forums.netbeans.org/platform-users.html. Anyway, when NB refuses
to start normally, clearing the userdir or starting the IDE with a
different userdir should be enough instead of needing to reinstall the
whole IDE - please see http://wiki.netbeans.org/FaqAlternateUserdir for
more info. As for the main issue, please do post this to the
aforementioned platform dev list, I'm sure the folks there will try to
help in resolving it.

Thanks,
Erno


amasino wrote:
Quote:
I have had a similar problem but it has not gone away after updating to JDK 6.20. Specifically, I am developing a NetBeans platform application on a Windows 7 Professional (x64) machine. On many occasions where I launch the app from NetBeans and it (the app under dev) encounters an exception the following occurs:

1. The app can no longer be started from NetBeans. When executing a clean and build and then run command the app appears to build, but is never launched
2. If I then close NetBeans, I cannot reopen it in the normal manner. If I double click the icon nothing happens. I can launch from a command prompt, but I get a message stating "The launcher has determined that the parent process has a console and will reuse it ...". When NetBeans is started in this manner, the dev app will not launch (same behavior as 1)
3. I do get an hs_err_pid# file. I can provide them if needed.
4. I can find no consistent way to resolve the problem other than reinstalling NetBeans, which is obviously less than ideal.

This problem does not occur on any of our 32 bit Vista machines.

Any help you could provide would be greatly appreciated.





Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> Ruby Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo