NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

At my wit's end (debugging a Rails 3.0/Ruby 1.9.2 app)
Goto page Previous  1, 2
 
Post new topic   Reply to topic    NetBeans Forums -> Ruby Users
View previous topic :: View next topic  
Author Message
djlewis



Joined: 01 Sep 2010
Posts: 5

PostPosted: Thu Sep 30, 2010 3:46 am    Post subject: Re: latest nightly works Reply with quote

corck wrote:
Hi,
just want to give an update. I downloaded the latest nightly, and I can use the debugger now.

Christoph

Not me. Downloaded the nightly on 9/29 (NetBeans IDE Build 201009291311) and it is "usable", but I still see the problem where breakpoints in one file actually display at the correct line but in a different source file (and a different file for each breakpoint)

Also, there are still problems with "find usages" and "refactor" -- they often pick up an enclosing block instead of the highlighted symbol.
Back to top
kwolf



Joined: 14 Nov 2010
Posts: 2
Location: Chicago, IL

PostPosted: Sun Nov 14, 2010 8:52 pm    Post subject: Still having issues. Reply with quote

I'm still seeing this even with 7.0 M2. Any updates?

rvm 1.0.21
rails 3.0.1
ruby 1.9.2

Code:

Fast Debugger (ruby-debug-ide 0.4.14, ruby-debug-base 0.11.25.jb) listens on 127.0.0.1:44297
        /home/kwolf/.rvm/gems/ruby-1.9.2-p0@scanner/gems/ruby-debug-ide-0.4.14/lib/ruby-debug-ide.rb:125:in `debug_load'
        /home/kwolf/.rvm/gems/ruby-1.9.2-p0@scanner/gems/ruby-debug-ide-0.4.14/lib/ruby-debug-ide.rb:125:in `debug_program'
        /home/kwolf/.rvm/gems/ruby-1.9.2-p0@scanner/gems/ruby-debug-ide-0.4.14/bin/rdebug-ide:87:in `<top (required)>'
        /home/kwolf/.rvm/gems/ruby-1.9.2-p0@scanner/bin/rdebug-ide:19:in `load'
        /home/kwolf/.rvm/gems/ruby-1.9.2-p0@scanner/bin/rdebug-ide:19:in `<main>'
Uncaught exception: no such file to load -- script/rails
Back to top
iioiooioo



Joined: 06 May 2010
Posts: 2

PostPosted: Tue Mar 27, 2012 5:33 pm    Post subject: Reply with quote

I adjusted baldmark's code to work on windows, too. Breakpoints are functional, for me.

Code:
if Debugger::PROG_SCRIPT == 'script/rails' || Debugger::PROG_SCRIPT == 'script\\rails'
  ps = Dir.pwd.chomp+'/script/rails'
else
  ps = Debugger::PROG_SCRIPT
end
bt = debug_load(ps, options.stop, options.load_mode)
Back to top
indancesky



Joined: 02 Aug 2012
Posts: 2

PostPosted: Thu Aug 02, 2012 6:27 am    Post subject: Reply with quote

When viewing the gems in the platform I've got the project set to, I do see all the appropriate gems including Rails 3.0.0. I also tried using Ruby 1.9.1 on the off chance that maybe NB didn't recognize 1.9.2 as 1.9, but that didn't make a difference.


Rc Helicopters Reviews|Rc Helicopter
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> Ruby Users All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo