NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

Issue with forums.netbeans.org and HTTPS Everywhere Firefox extension

 
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Community Corner
View previous topic :: View next topic  
Author Message
skissane



Joined: 06 Nov 2013
Posts: 1

PostPosted: Wed Nov 06, 2013 1:53 am    Post subject: Issue with forums.netbeans.org and HTTPS Everywhere Firefox extension Reply with quote

Hi

I hope this is an appropriate place to bring this up. For several days now I have been unable to access "forums.netbeans.org". Whenever I went to it in my browser, I got just a page that said "services.netbeans.org, https". I could not work out what was going on.

Today I worked out the problem: I had installed the HTTPS Everywhere Firefox extension - https://www.eff.org/https-everywhere - whenever one goes to a HTTP page, it checks if the same page is available via HTTPS, and if it is, it sends you to the HTTPS page instead.

The problem with forums.netbeans.org, is it confuses this extension, because it does serve up HTTPS, but it does not serve up the actual website over HTTPS, just that confusing message. The solution is to edit the HTTPS Everywhere settings to exclude forums.netbeans.org.

But I think, to stop this, one of two things should be done. Either, forums.netbeans.org should be changed to serve up the actual forums over HTTPS, instead of that message. Alternatively, HTTPS should be turned off on forums.netbeans.org, so this cannot happen.

Also, it might be helpful to post something somewhere about this, in case other people run into the same issue. Obviously a post on this site won't help anyone with this problem, but maybe a notice on this page might - https://netbeans.org/community/lists/

Thanks
Simon
Back to top
tinu



Joined: 09 Jul 2008
Posts: 28
Location: Prague

PostPosted: Thu Nov 07, 2013 2:47 pm    Post subject: Reply with quote

Simon,

Thank you reporting your experience. I'll pass this on to our webmaster.

Tinu
Back to top
SandraPaker



Joined: 13 Nov 2013
Posts: 1

PostPosted: Wed Nov 13, 2013 12:18 pm    Post subject: Reply with quote

Obviously! One of my friends also facing such an issue, hope this might give her a decent idea about the certain matter, worth sharing though!
Back to top
tinu



Joined: 09 Jul 2008
Posts: 28
Location: Prague

PostPosted: Wed Nov 13, 2013 4:44 pm    Post subject: Reply with quote

Hello Simon,

This issue has been fixed.
Thank you again for bringing it to our attention.

Tinu
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Community Corner All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo