NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

Remote Synchronization, Upload, Download Disabled for just one folder

 
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Users
View previous topic :: View next topic  
Author Message
upTree



Joined: 15 Jan 2016
Posts: 4

PostPosted: Tue Feb 23, 2016 4:55 pm    Post subject: Remote Synchronization, Upload, Download Disabled for just one folder Reply with quote

Hi guys,

I'm stuck with a problem of being unable to remote sync, upload, and download one single folder in my project. All other folders/files are fine for syncing, uploading, and downloading. Screenshot attached.

I am able to edit the files and they automatically save to the server fine, but when I right click the folder to sync, those menu options are greyed out as seen in the screenshot.

I created a clean project and downloaded the project from the server, but problem still exists! The permissions are the same as all the other files/folders in the project.

Does anyone know if there is some NetBeans setting that I might have accidentally turned on for this folder, like some "disable remote sync for this folder" type thing. I have no idea...

Thanks!



netbeans-sync-disabled-01.jpg
 Description:
Screenshot of what I see when I try to sync this one folder.
 Filesize:  20.62 KB
 Viewed:  4270 Time(s)

netbeans-sync-disabled-01.jpg


Back to top
upTree



Joined: 15 Jan 2016
Posts: 4

PostPosted: Sat Mar 19, 2016 11:48 am    Post subject: Reply with quote

This is now occurring randomly on a few folders in each of my projects. I have absolutely no idea what is causing it, and it's driving me insane. I've googled to the depths of the internet and have found nothing.

I've even installed a fresh copy of Netbeans on a fresh install of Windows10 (upgraded from Windows 7) and the problem persists.
Back to top
toni2016



Joined: 20 Mar 2016
Posts: 1

PostPosted: Sun Mar 20, 2016 7:13 am    Post subject: Same Problem on MacOsX with Netbeans 8.1 Reply with quote

Hi,
i have the same problem and have no idea what it is caused by...
i checked local and remote file/folder permissions, cleared Netbeans Caches, deleted .DS_STORE, recreated project...still the same.
When i right mouse click on some folders, upload/download/sync-Options are disabled...
any idea? did you solve the Problem?
thanks

EDIT: Check for a "Gruntfile" or "package.json" inside of the folders!
Back to top
upTree



Joined: 15 Jan 2016
Posts: 4

PostPosted: Sun Mar 20, 2016 9:01 am    Post subject: Re: Same Problem on MacOsX with Netbeans 8.1 Reply with quote

toni2016 wrote:

EDIT: Check for a "Gruntfile" or "package.json" inside of the folders!


Thanks for your reply, and sorry that you're also having to deal with this extremely frustrating situation. I checked and don't have the files you mentioned in the problem folders. I've also compared syncable folders with the problem/non-syncable folders, and I'm unable to get any clues that way. Nothing is common between the problem folders. I'm working on a web project and all folders (working and non-working) just contain php, js, css files, etc. - nothing special.

I will continue searching for a solution and will post back here as soon as I find one.
Back to top
mslade



Joined: 24 Sep 2015
Posts: 4

PostPosted: Tue Apr 19, 2016 1:34 pm    Post subject: Reply with quote

I also have this issue and found a work around that works for me until the bug gets a proper fix.

In my case, the bug is triggered by the presence of package.json. If that file is in my directory, I can't download/upload/sync anything under that directory. If I rename it to .package.json and restart Netbeans, download/upload/sync work correctly. I just have to be careful not to commit my change. Adding package.json to the to the list of ignored files didn't help, unfortunately.

I'd love to know what plugin is doing this so I can put it in front of a firing squad, or at least submit a bug report. I deactivated a bunch that I thought might be causing it, but no such luck.
Back to top
vudologic



Joined: 20 Jun 2016
Posts: 1

PostPosted: Mon Jun 20, 2016 10:04 pm    Post subject: Reply with quote

Hi Guys,

Has anyone found a solution to this problem? I am having this problem as well and I am yanking my hair out trying to resolve this.

Any help would be greatly appreciated. Thanks in advance!
Back to top
mctenreiro@hotmail.com



Joined: 07 Mar 2017
Posts: 1

PostPosted: Tue Mar 07, 2017 6:43 pm    Post subject: I Got it! Reply with quote

Just delete composer.json from root folder... Restart the IDE...
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo