NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

Java EE EJB Module on TomEE

 
Post new topic   Reply to topic    NetBeans Forums -> Java EE Users
View previous topic :: View next topic  
Author Message
CarlosFMeneses



Joined: 22 Mar 2016
Posts: 10

PostPosted: Fri Jun 17, 2016 6:03 am    Post subject: Java EE EJB Module on TomEE Reply with quote

I'm trying to create an EJB project using the wizard via New Project > Java EE > EJB Module and the wizard does not give me the option to use TomEE as the server.

I do have the Apache TomEE+ 1.7.4 set up as a server in the Services tab. I have tried running TomEE with both the default installation and a modified install/server.xml as shown https://youtu.be/twX8oTMWqbY.

Did I miss something or is an EJB project no supported with TomEE?
Back to top
mauro_netbeans



Joined: 18 Jun 2016
Posts: 5

PostPosted: Sat Jun 18, 2016 8:17 am    Post subject: activate module EJB for tomee Reply with quote

Hi. netbeans not recognize tomee like a JEE server because internally it check some name of jar into tomee/lib.

The netbeans code it check for only 3 segment of the name of jar.
And tomee came with 4 segment for names of jars.
So you have to rename a name of 1 jar fiel at only 3 segments.
Go at:

https://netbeans.org/bugzilla/show_bug.cgi?id=237453#c11
and

https://www.youtube.com/watch?v=89s6zhI6sK0

and go at min 3:02 to 3:28
It explain the workaround.
Let me know if you have resolved.

It is a solution proposed from Kay Wrobel the writer of plugin Primefaces crud generation

Mauro
Back to top
CarlosFMeneses



Joined: 22 Mar 2016
Posts: 10

PostPosted: Wed Sep 21, 2016 5:34 am    Post subject: Re: activate module EJB for tomee Reply with quote

mauro_netbeans wrote:
The netbeans code it check for only 3 segment of the name of jar.
And tomee came with 4 segment for names of jars.
So you have to rename a name of 1 jar fiel at only 3 segments.


Hello Mauro. Thank you, and so sorry for the late reply, but I had put Apache TomEE aside since I was spending to much time trying to figure all that out.

Unfortunately I'm back again with TomEE and still haven't figure this out. According to the bug report link and the video you posted, this should have been debugged at NB v8.0. I am using NB v8.1 and Apache TomEE+ 1.7.4 (file name tomee-common-1.7.4.jar file in lib folder).

Any other thoughts?
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> Java EE Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo