NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

"Unable to start pty process" and failing Welcome project

 
Post new topic   Reply to topic    NetBeans Forums -> C/C++ Users
View previous topic :: View next topic  
Author Message
Daveoh



Joined: 27 Jul 2013
Posts: 1

PostPosted: Sat Jul 27, 2013 4:40 am    Post subject: "Unable to start pty process" and failing Welcome project Reply with quote

Hello,

I haven't been able to find much on this. I have installed Netbeans 7.3.1 for C++ and MinGW. My tool collection is set to MinGW and the make command is set to \msys\1.0\bin\make.exe. If my project's Properties - Run - Console Type is set to "Internal Terminal" then it fails to run. Here is the error:

Code:
Unable to start pty process:

RUN FAILED (exit value -2, total time: 29ms)


If I set it to "External Terminal" then it runs.

However now I have another problem. Previously I tried the Welcome project with a Cygwin tool collection and it ran as expected, but now I have installed MinGW then it fails to run properly. Only the first cout statement appears to be executed. Here is the terminal output:

Code:
Welcome ...Press [Enter] to close the terminal ...


And here is the Netbeans console output:

Code:
Process is started in an external terminal ...


RUN FAILED (exit value 127, total time: 351ms)


I haven't used Netbeans before. Is it set up incorrectly or is there a bug? I have found a couple of previous topics about this on these forums, however the problem was never looked into.
Back to top
WhoCanReadThatCaptcha



Joined: 19 Feb 2012
Posts: 1

PostPosted: Sat Aug 10, 2013 8:56 am    Post subject: Reply with quote

I have also had the same issue.

I have used cygwin 1.7.22 and 1.7.23.
I have installed the lastest MingW as of 8/10/2013. Same issue.

It sounds like this bug: https://netbeans.org/bugzilla/show_bug.cgi?id=194328

I have also tried "Standard Output". I get the following message:

0 [main] helloworld 8912 D:\dev\helloworld\dist\Debug\Cygwin_4.x_1-Windows\helloworld.exe: *** fatal error - error while loading shared libraries: /cygdrive/C/Program Files/NetBeans 7.3.1/ide/bin/nativeexecution/Windows-x86/unbuffer.dll: cannot open shared object file: Exec format error
373 [main] helloworld 8912 open_stackdumpfile: Dumping stack trace to helloworld.exe.stackdump

As a temporary fix you can right click on the project go to "Properties". Click on "Run". In there change "Console Type" to "External Terminal". This creates a cmd window externally of NetBeans.
Back to top
soldatov



Joined: 05 Nov 2009
Posts: 441

PostPosted: Sat Aug 10, 2013 12:47 pm    Post subject: Reply with quote

I filed https://netbeans.org/bugzilla/show_bug.cgi?id=234221
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> C/C++ Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo