NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

Netbeans connector disconnects when I open CDT.

 
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Users
View previous topic :: View next topic  
Author Message
KenOtwell



Joined: 25 Feb 2017
Posts: 4

PostPosted: Sat Mar 11, 2017 9:19 pm    Post subject: Netbeans connector disconnects when I open CDT. Reply with quote

Cannot seem to get the Chrome/Netbeans thing right. I have the latest versions of both, I reinstalled the connector plugin, but when I'm connected and open the Chrome dev tools, it breaks the connection, and when I try to reconnect, it tells me to close CDT.

Now what? And furthermore (it may be relevent) I can't get JavaScript to debug at all in my Web Java program, with our without the connector working.
Back to top
Papa



Joined: 17 Sep 2016
Posts: 23

PostPosted: Sun Mar 12, 2017 1:21 pm    Post subject: Netbeans connector disconnects when I open CDT. Reply with quote

Have you tried Firefox or Waterfox?

On 11-Mar-2017 4:19 PM, KenOtwell wrote:
Quote:
Cannot seem to get the Chrome/Netbeans thing right. I have the latest versions of both, I reinstalled the connector plugin, but when I'm connected and open the Chrome dev tools, it breaks the connection, and when I try to reconnect, it tells me to close CDT.

Now what? And furthermore (it may be relevent) I can't get JavaScript to debug at all in my Web Java program, with our without the connector working.



Back to top
KenOtwell



Joined: 25 Feb 2017
Posts: 4

PostPosted: Sun Mar 12, 2017 6:46 pm    Post subject: Re: Netbeans connector disconnects when I open CDT. Reply with quote

Papa wrote:
Have you tried Firefox or Waterfox?


No - I did try Edge but there's no debug connector from NetBeans anyway. It's the weirdest thing - I followed an online video tutorial for debugging JavaScript in NetBeans and it just doesn't work as advertised on my new installation of NetBeans 8.2.
Back to top
geertjan



Joined: 22 Jan 2014
Posts: 978

PostPosted: Mon Mar 13, 2017 10:24 am    Post subject: Netbeans connector disconnects when I open CDT. Reply with quote

I'd be happy to take a look at it with you, on Skype my username is
geertjanwielenga.

I'd be happy to do a demo of how this functionality works with you and
take a look at what's going wrong on your end.

Gj


On 12-3-2017 19:46, KenOtwell wrote:
Quote:
Papa wrote:
Quote:
Have you tried Firefox or Waterfox?


No - I did try Edge but there's no debug connector from NetBeans anyway. It's the weirdest thing - I followed an online video tutorial for debugging JavaScript in NetBeans and it just doesn't work as advertised on my new installation of NetBeans 8.2.



Back to top
Papa



Joined: 17 Sep 2016
Posts: 23

PostPosted: Mon Mar 13, 2017 11:17 am    Post subject: Netbeans connector disconnects when I open CDT. Reply with quote

Hmm.
What nice person, truly, what a nice person you are.
All the power to you man. It shows the quality of people in this group.
Have wonderful day.


Sent from my LG Mobile



------ Original message------
From: geertjan wielenga
Date: Mon, Mar 13, 2017 6:54 AM
To: address-removed ([email]address-removed[/email]);
Subject:[nbusers] Re: Netbeans connector disconnects when I open CDT.



Quote:
I'd be happy to take a look at it with you, on Skype my username is geertjanwielenga.I'd be happy to do a demo of how this functionality works with you and take a look at what's going wrong on your end.GjOn [url=tel:12-3-2017 19]12-3-2017 19[/url]:46, KenOtwell wrote:> Papa wrote:>> Have you tried Firefox or Waterfox?>>>> No - I did try Edge but there's no debug connector from NetBeans anyway. It's the weirdest thing - I followed an online video tutorial for debugging JavaScript in NetBeans and it just doesn't work as advertised on my new installation of NetBeans 8.2.>>>>
Back to top
KenOtwell



Joined: 25 Feb 2017
Posts: 4

PostPosted: Mon Mar 13, 2017 11:43 pm    Post subject: ARggg!! Reply with quote

I think I figured it out.. you can only debug JavaScript when running an HTML5/JS application from node.js. (I got that to work.)

But I'm running a Java web app with JS resource files... and those can't be debugged. You can debug Java OR JavaScript, but not both in the same project. Am I correct?
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo