NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

Initializing tools collection on localhost hangs

 
Post new topic   Reply to topic    NetBeans Forums -> C/C++ Users
View previous topic :: View next topic  
Author Message
zwilcox



Joined: 29 Sep 2015
Posts: 2

PostPosted: Tue Sep 29, 2015 7:30 pm    Post subject: Initializing tools collection on localhost hangs Reply with quote

I just installed Netbeans 8.0.2.

When I try to create a new C++ application, "Initializing tools collection on localhost" hangs

Same thing happens if I try to import an existing netbeans C++ project.

I'm unable to add the Cygwin tools by going to Tools >> Options >> C++
because, you guessed it, it is hung up on "Initializing tools collection on localhost"



hung2.PNG
 Description:
 Filesize:  53.77 KB
 Viewed:  3884 Time(s)

hung2.PNG



hung1.PNG
 Description:
 Filesize:  119.3 KB
 Viewed:  3884 Time(s)

hung1.PNG



hung.png
 Description:
 Filesize:  49.69 KB
 Viewed:  3884 Time(s)

hung.png


Back to top
zwilcox



Joined: 29 Sep 2015
Posts: 2

PostPosted: Tue Sep 29, 2015 9:20 pm    Post subject: Reply with quote

So I fixed it.
I open Process Explorer and tried again.
nebeans opens up bash. For some reason my .bash_profile opened up zsh (which i was using as my default shell).

I removed zsh from being launched and it seems to work fine now.



Capture.PNG
 Description:
 Filesize:  6.99 KB
 Viewed:  3876 Time(s)

Capture.PNG


Back to top
themba__



Joined: 14 Mar 2016
Posts: 2

PostPosted: Mon Mar 14, 2016 12:38 pm    Post subject: Reply with quote

If it helps anyone: I solved this issue by uninstalling hardening-wrapper from my archlinux installation.
Back to top
netizensmith



Joined: 28 Mar 2017
Posts: 1

PostPosted: Tue Mar 28, 2017 3:52 pm    Post subject: Reply with quote

In case it helps anyone else:

I had this problem on my home Win10 machine using netbeans 8.2. None of the suggestions anywhere else worked. I got it to work by installing cygwin with the g++ compiler and ssh. Originally I had neither the Mingw or cygwin on there. I put mingw on but no joy, uninstalled that and put cygwin on (64 bit) and all working now.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> C/C++ Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo