NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

starting of tomcat failed

 
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Platform Users
View previous topic :: View next topic  
Author Message
keshavagrawal_89



Joined: 19 Oct 2010
Posts: 15
Location: India

PostPosted: Sun Oct 24, 2010 5:48 am    Post subject: starting of tomcat failed Reply with quote

Whenever i start my netbeans 6.9.1 and run a simple web project containing two jsp pages only, then i get an error message : Starting of tomcat 6 failed. Port 8084 is already in use.

I cannot see my webpage. But when i type "http://localhost:8084/index.jsp" in the browser then i get to see the deafault page of Apache Tomcat.

Why then it is showing "port already in use" kind of error when i deploy my project from netbeans 6.9.1 ?

please suggest

Thanks in advance
Back to top
Charles Bedon
Posted via mailing list.





PostPosted: Tue Oct 26, 2010 1:22 pm    Post subject: [platform-dev] Re: starting of tomcat failed Reply with quote

Hello

Is Tomcat starting as a Windows/Linux service in your computer? did you try not "running" the application but only "deploying" it?

2010/10/24 keshavagrawal_89 <address-removed ([email]address-removed[/email])>
Quote:
Whenever i start my netbeans 6.9.1 and run a simple web project containing two jsp pages only, then i get an error message : Starting of tomcat 6 failed. Port 8084 is already in use.

I cannot see my webpage. But when i type "http://localhost:8084/index.jsp" in the browser then i get to see the deafault page of Apache Tomcat.

Why then it is showing "port already in use" kind of error when i deploy my project from netbeans 6.9.1 ?

please suggest

Thanks in advance







--
Charles Edward Bed
Back to top
keshavagrawal_89



Joined: 19 Oct 2010
Posts: 15
Location: India

PostPosted: Fri Oct 29, 2010 12:46 am    Post subject: Reply with quote

i didnt install tomcat separately so how can windows start without netbeans.. i mean during the installation of netbeans 6.9.1 it installed tomcat automatically so it Tomcat starts only when i run my project. and whenever i run my project it displays : Waiting for tomact to start. But it doesnt start and after 3 mins it shows tomact could not start. Please see the server log. And once that error occurs from there on if i try to run the project it shows : Port 8084 is already in use. After i exit and restart netbeans an then agian run then agian the cycle starts At first : Cannot start and after that : Port already in use.. I tried to install netbeans again after uninstalling it and deleting all its previous files but the problem persists. At present i am using Netbeans 7.0 M2 but the problem is still there.. I cant view a single "Hello world" page through netbeans..

Please let me know if more information is needed
Thanks
Back to top
Charles Bedon
Posted via mailing list.





PostPosted: Fri Oct 29, 2010 4:29 pm    Post subject: [platform-dev] Re: starting of tomcat failed Reply with quote

Hello

No server log was attached to your mail. What's the output of "netstat -a" in the command prompt *before* you try to run the project?

2010/10/28 keshavagrawal_89 <address-removed ([email]address-removed[/email])>
Quote:
i didnt install tomcat separately so how can windows start without netbeans.. i mean during the installation of netbeans 6.9.1 it installed tomcat automatically so it Tomcat starts only when i run my project. and whenever i run my project it displays : Waiting for tomact to start. But it doesnt start and after 3 mins it shows tomact could not start. Please see the server log. And once that error occurs from
Back to top
keshavagrawal_89



Joined: 19 Oct 2010
Posts: 15
Location: India

PostPosted: Sun Oct 31, 2010 12:40 am    Post subject: Re: [platform-dev] Re: starting of tomcat failed Reply with quote

[quote="Charles Bedon"]Hello

No server log was attached to your mail. What's the output of "netstat -a" in the command prompt *before* you try to run the project?

2010/10/28 keshavagrawal_89 <address-removed ([email]address-removed[/email])>
Quote:
i didnt install tomcat separately so how can windows start without netbeans.. i mean during the installation of netbeans 6.9.1 it installed tomcat automatically so it Tomcat starts only when i run my project. and whenever i run my project it displays : Waiting for tomact to start. But it doesnt start and after 3 mins it shows tomact could not start. Please see the server log. And once that error occurs from


Hello,
When i run my netbeans 7 i hav 3 tabs in my output pane : 1) Webapplication1(run) 2) Apache Tomcat 6.0.29 and 3) Apache Tomcat 6.0.29 log.

and i have attached the notepad files here which reflects the output on my system for each tab. There is nothing in the "Apache Tomcat 6.0.29 log" tab..!
And one more thing is it safe to post the output of netstat -a here ? I mean it contains the addresses of my pc so may i ask what is exactly needed to be known in particular from its output? Then i can post it.



webapplication(run).txt
 Description:
under "WebApplication1(run)" tab

Download
 Filename:  webapplication(run).txt
 Filesize:  1.72 KB
 Downloaded:  99 Time(s)


Apache Tomcat 6.0.29.txt
 Description:
under "Apache Tomcat 6.0.29" tab

Download
 Filename:  Apache Tomcat 6.0.29.txt
 Filesize:  2 KB
 Downloaded:  123 Time(s)

Back to top
Charles Bedon
Posted via mailing list.





PostPosted: Mon Nov 01, 2010 1:15 pm    Post subject: [platform-dev] Re: starting of tomcat failed Reply with quote

Hello

I don't see any reference to a port already in use in the logs you attached:


"Oct 31, 2010 5:45:20 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 993 ms"


That should mean that the server started correctly. The netstat thing is just to know if that port is already in use (at least for the operating system).
Have you tried to start the server using the command line and then just deploying the application instead of running it in Netbeans?


I had a problem with Glassfish once because it's installed by default in c:\, but Win7 restricts the access to any folder in this location (no matter if you were running the process as admin, which is anyway a bad idea) and the server was not able to start. That happens in "Program Files" folder as well. If the port is not the problem (And I don't think it is) maybe you could try to run it:


1. From the command line in the current location
2. From the command line but the server directory copied into your user folder.

2010/10/30 keshavagrawal_89 <address-removed ([email]address-removed[/email])>
Quote:
[quote="Charles Bedon"]Hello

No server log was attached to your mail. What's the output of "netstat -a" in the command prompt *before* you try to run the project?


2010/10/28 keshavagrawal_89 <address-removed (address-removed)>

Quote:
i didnt install tomcat separately so how can windows start without netbeans.. i mean during the installation of netbeans 6.9.1 it installed tomcat automatically so it Tomcat starts only when i run my project. and whenever i run my project it displays : Waiting for tomact to start. But it doesnt start and after 3 mins it shows tomact could not start. Please see the server log. And once that error occurs from



Hello,
When i run my netbeans 7 i hav 3 tabs in my output pane : 1) Webapplication1(run) 2) Apache Tomcat 6.0.29 and 3) Apache Tomcat 6.0.29 log.

and i have attached the notepad files here which reflects the output on my system for each tab. There is nothing in the "Apache Tomcat 6.0.29 log" tab..!
And one more thing is it safe to post the output of netstat -a here ? I mean it contains the addresses of my pc so may i ask what is exactly needed to be known in particular from its output? Then i can post it.




Attachments:
http://forums.netbeans.org//files/webapplicationrun_156.txt
http://forums.netbeans.org//files/apache_tomcat_6029_139.txt




--
Charles Edward Bed
Back to top
keshavagrawal_89



Joined: 19 Oct 2010
Posts: 15
Location: India

PostPosted: Tue Nov 02, 2010 2:21 am    Post subject: Reply with quote

I am doing some research on my files. Will return back and let you know if i dont get my tomcat started.. Thanks for all your help.. Smile
Back to top
abn.soft



Joined: 15 Sep 2010
Posts: 1

PostPosted: Tue Nov 16, 2010 10:57 am    Post subject: [platform-dev] How to add new myself items into "NEW PROJECT" ? Reply with quote

Hello


How to add new myself items into "NEW PROJECT" ?




--
Best regards,
Andre
Back to top
Alexander Graf
Posted via mailing list.





PostPosted: Tue Nov 16, 2010 2:57 pm    Post subject: [platform-dev] Re: How to add new myself items into "NEW PROJECT" ? Reply with quote

See the module type tutorial:

http://platform.netbeans.org/tutorials/nbm-projecttype.html

regards
Alex

Quote:
Hello


How to add new myself items into "NEW PROJECT" ?

Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> NetBeans Platform Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo