NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  

xdebug 7.2 xampp no connection from xdebug

 
Post new topic   Reply to topic    NetBeans Forums -> PHP Users
View previous topic :: View next topic  
Author Message
itbyainsworth



Joined: 01 Sep 2012
Posts: 1

PostPosted: Sun Sep 02, 2012 12:21 am    Post subject: xdebug 7.2 xampp no connection from xdebug Reply with quote

I am using NetBeans 7.2 for PHP development and am trying to use xdebug. When I invoke the debugger i get the message at the bottom that says waiting for connection forever I get the following: No Connection from xdebug when I finally stop it

I am using XAMPP 3.0.12 (php 5.4)

my http port for Apache is 8084

here is the xdebug section of my php.ini
[XDebug]
zend_extension = C:\xampp\php\ext\php_xdebug-2.2.1-5.4-vc9.dll
xdebug.auto_trace = On
xdebug.collect_includes = 1
xdebug.collect_params = 0
xdebug.collect_return = 0
xdebug.collect_vars = "Off"
xdebug.default_enable = "On"
; xdebug.dump.SERVER = REMOTE_ADDR,REQUEST_METHOD
; xdebug.dump.SERVER = REMOTE_ADDR,REQUEST_METHOD
;xdebug.dump.COOKIE = ""
;xdebug.dump.FILES = ""
;xdebug.dump.GET = ""
;xdebug.dump.POST = ""
;xdebug.dump.REQUEST = ""
;xdebug.dump.SERVER = ""
;xdebug.dump.SESSION = ""

;xdebug.dump_globals = 1

xdebug.dump_once = 1
;xdebug.dump_undefined = 0
xdebug.extended_info = 1
;xdebug.file_link_format = ""
xdebug.idekey="netbeans-xdebug"
;xdebug.manual_url = "http://www.php.net"
;xdebug.max_nesting_level = 100
;xdebug.overload_var_dump = 1

; xdebug.profiler_append
; Type: integer, Default value: 0
; When this setting is set to 1, profiler files will not be overwritten when a new request would map
; to the same file (depnding on the xdebug.profiler_output_name setting. Instead the file will be
; appended to with the new profile.
xdebug.profiler_append = 0
xdebug.profiler_enable = 0
xdebug.profiler_enable_trigger = 0
xdebug.profiler_output_dir = "C:\xampp\tmp"
xdebug.profiler_output_name = "xdebug_profile.%R::%u"
;xdebug.remote_autostart = 0
;xdebug.remote_enable = "On"
xdebug.remote_handler = "dbgp"
xdebug.remote_host = "localhost"
;xdebug.remote_log = "none"
xdebug.remote_mode = "req"
xdebug.remote_port = 9000
;xdebug.show_exception_trace = 0
;xdebug.show_local_vars = 0
;xdebug.show_mem_delta = 0
;xdebug.trace_format = 0
;xdebug.trace_options = 0
xdebug.trace_output_dir = "C:\xampp\tmp"
xdebug.trace_output_name = "trace.%c"
;xdebug.var_display_max_children = 128
;xdebug.var_display_max_data = 512
;xdebug.var_display_max_depth = 3

I have checked that NetBeans xdebug port is 9000

I have reviewed an older post (2008) but it did not seem to be very useful for my situation

If anyone has any ideas, it would be appreciated
Back to top
paolosca



Joined: 09 Sep 2010
Posts: 417

PostPosted: Mon Sep 03, 2012 8:54 am    Post subject: xdebug 7.2 xampp no connection from xdebug Reply with quote

Hi,

I think I read a post on this list where a Windows user had problems
with localhost. You may try to replace it localhost with your
workstation's IP number in the following line:

xdebug.remote_host = "localhost"

In example:

xdebug.remote_host = 192.168.1.2


Other users had problems with the Windows firewall so you may want to
check that as well.


If you don't set a parameter xdebug will just use the default value so
it's not necessary to specify all the xdebug options in php.ini. Unless
you have specific needs just leave the few recommended by NetBeans, it
will be much easier to identify the problem.

I just use the following settings (Linux):

xdebug.remote_enable=on
xdebug.remote_handler=dbgp
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.show_local_vars=on
xdebug.output_buffering=off


Regards,


Paolo
Back to top
abombthecoder



Joined: 27 Mar 2013
Posts: 3

PostPosted: Wed Mar 27, 2013 8:29 am    Post subject: Reply with quote

TY paolosca, you helped save my day/night/and the next day.

Windows 7 user with xampp 1.8.1, I had to enter in my ip address 127.0.0.1, localhost wasn't working.

[XDebug]
zend_extension = C:\xampp\php\ext\php_xdebug.dll
xdebug.remote_enable=1
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.remote_handler=dbgp

TO THE PARANOID ADMINS: It was horrible trying to sign up for this forum, and it's horrible to even post. You guys are so paranoid about spam, many more popular forums don't have such ridiculous security measures. The only reason I followed through with registration and posting is to help other window users not waste hours of their precious existence futzing with their ini file.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> PHP Users All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo