NetBeans Forums

 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Debugging (breakpoints) not working when using Series 40 6th ed. SDk (solved)

Post new topic   Reply to topic    NetBeans Forums -> Java ME Users
View previous topic :: View next topic  
Author Message

Joined: 05 Nov 2012
Posts: 12

PostPosted: Tue May 10, 2016 1:07 pm    Post subject: Debugging (breakpoints) not working when using Series 40 6th ed. SDk (solved) Reply with quote

solved, see

=== original post ===

When I'm trying to use Series 40 6th ed. SDK no breakpoints are hit, it works though when I'm using e.g. ME SDK 3.4

This is the debug output I get


Emulator command: H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\bin\S40_6th_Edition_SDK_em.exe -debugger -vm_port 49152 -Xdomain:trusted "[myFilepath].jad"
Creating New "Series 40 6th Edition SDK" Instance ...
Debug proxy command: kdp.KVMDebugProxy -l 57816 -p -r localhost 49152 -classpath H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\midp21.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\midp20.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\midp10.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\cldc11.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\cldc10.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\jsr82.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\3dapi.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\amms.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\jsr172.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\jsr75.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\mmapi12.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\satsa-apdu.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\satsa-crypto.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\svg11.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\wma20.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\wma11.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\nokiaui.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\jsr211.jar;H:\JAVA_SDKs_JDKs\SDKs\S40_6th_Edition_SDK\lib\jsr179.jar;[myFilepath].jar
Connecting to localhost on port 49152
Waiting for KVM...
Connected to KVM
Waiting for debugger on port 57816
Loading SdkConfig.dll
Loading sdk.dll
Adding 36 second for debugger timeout
KdpDebugTask connecting to debugger 1 ..
Connection received.
WARNING: Unrecognized argument 4: -Xdomain:trusted
Smart card communication error 0x80100017
The specified reader is not currently available for use
Using Maximum simulated domain
Debugger could not bind listenSocket
Debugger FD select failed
"Series 40 6th Edition SDK" Instance #6260000 Ready for Future Connections

Any ideas what could be the problem ?
Back to top

Joined: 17 May 2014
Posts: 3

PostPosted: Fri Jul 01, 2016 5:48 pm    Post subject: Reply with quote

this is great stuff!
Back to top
Display posts from previous:   
Post new topic   Reply to topic    NetBeans Forums -> Java ME Users All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo